Apple's iOS Harbors Security Flaw, Germany Warns

Opening infected PDFs could install malware
By Kevin Spak,  Newser Staff
Posted Jul 7, 2011 12:50 PM CDT
Apple iPads, iPhones and iPods Vulnerable to 'Critical' iOS Security Flaw, Expert Warns
In this 2010 file photo, customers are silhouetted at the launch of the iPad at an Apple store in Rome.   (AP Photo/Angelo Carconi, File)

IPads, iPhones, and iPods are all vulnerable to “critical weaknesses” that could “allow possible attackers to gain administrator rights and get access to the entire system,” Germany’s IT security agency warned today. Clicking on an infected PDF could allow attackers to install malware without your knowledge, which would then allow them to spy on passwords, read your email, or even listen to your phone calls, the federal agency warned. Apple says it's aware of the issue and is working on a fix.

The flaw was first exposed by hackers trying to “jailbreak” the iPhone—that is, allow it to run programs not approved by Apple, the Guardian reports. The hackers released a fix on their site, jailbreakme.com, but it works only on "jailbroken" devices. “I think there's a good chance the security impact of these vulnerabilities will remain theoretical,” the site’s FAQ reads, but “until Apple releases an update, jailbreaking will ironically be the best way to remain secure.” (Read more iPad stories.)

We use cookies. By Clicking "OK" or any content on this site, you agree to allow cookies to be placed. Read more in our privacy policy.
Get the news faster.
Tap to install our app.
X
Install the Newser News app
in two easy steps:
1. Tap in your navigation bar.
2. Tap to Add to Home Screen.

X